买好股公式网 > 股票公式 > 飞狐公式 > 飞狐霸王举鼎选股公式源码

飞狐霸王举鼎选股公式源码

2013年05月16日 【字体: 人气:

FO:=OPEN;
FH:=HIGH;
FL:=LOW;
FC:=CLOSE;
<%
vo=ffl.vardata("fo")
vh=ffl.vardata("fh")
vl=ffl.vardata("fl")
vc=ffl.vardata("fc")
last=ubound(vc)
vc(0)=(vh(0)+vl(0)+2*vc(0))/4
for i=1 to last
vo(i)=(vo(i-1)+vc(i-1))/2
if vo(i)>vh(i) then vh(i)=vo(i) else vh(i)=vh(i)
if vo(i)<vl(i) then vl(i)=vo(i) else vl(i)=vl(i)
vc(i)=(2*vc(i)+vh(i)+vl(i))/4
next
ffl.vardata("fo")=vo
ffl.vardata("fh")=vh
ffl.vardata("fl")=vl
ffl.vardata("fc")=vc
%>
KK:=IF(FC>=FO AND (FC>=REF(FC,1) OR REF(FC,1)>=REF(FO,1)),1,IF(FC<FO AND (FC<REF(FO,1) OR REF(FC,1)<REF(FO,1)),-1,0));
红K1:=KK=1 AND FC>=FO;
红K2:=KK=1 AND FC<FO;
红K3:=KK=0 AND FC>=FO;
红K:=红K1 OR 红K2 OR 红K3;
DIFF:=(EMA(C,26)-EMA(C,52));
DEA:=EMA(DIFF,52);
MACD:=(2*(DIFF-DEA));
DIF:=(EMA(C,26)-EMA(C,52));
ESS:=EMA(C,26);
EGG:=EMA(C,52);
西楚霸王:=(((((((((52-1)*(26+1))*EGG)*1)-((((52+1)*(26-1))*ESS)*1))+(((26+1)*(52+1))*DIF))*1)/((2*52)-(2*26)))*1),colorYELLOW;
霸王线多头:=西楚霸王>=REF(西楚霸王,1);
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
买入:=CROSS(K,D);
霸王举鼎:红K AND 霸王线多头 AND 买入;

飞狐霸王举鼎选股指标公式

 

0% (0)
0% (10)

关于飞狐霸王举鼎选股公式源码的评论:

 以下是对 [飞狐霸王举鼎选股公式源码] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们