买好股公式网 > 股票公式 > 大智慧公式 > 大智慧分时KDJ+MACD+RSI背离公式

大智慧分时KDJ+MACD+RSI背离公式

2011年04月27日 字体: 人气:

Input:N(10),M1(3),M2(3);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
POLYLINE(1,D),colorFFFF00;
短高:IF(BETWEEN("KDJ.K",100,80),88,100),PRECIS0;
短低:IF(BETWEEN("KDJ.K",20,0),12,0),PRECIS0;
波低:IF(BETWEEN("KDJ.K#week",10,0),30,0),PRECIS0;
波高:IF(BETWEEN("KDJ.K#week",100,90),70,100),PRECIS0;
中低:IF(BETWEEN("KDJ.K#MONTH",20,0),30,0),PRECIS0,color0000FF;
中高:IF(BETWEEN("KDJ.K#MONTH",100,75),70,100),PRECIS0;
POLYLINE(1,0),color00FFFF;
A1:=BARSLAST(REF(CROSS("MACD.DIFF","MACD.DEA"),1));
B1:=REF(CLOSE,A1+1)>CLOSE AND REF("MACD.DIFF",A1+1)<"MACD.DIFF" AND CROSS("MACD.DIFF","MACD.DEA");
MACD底背离:FILTER(B1>0,5),LineThick0,PRECIS0;
STICKLINE(FILTER(B1>0,5),0,10,3,0),color00FF00;
DRAWTEXT(FILTER(B1>0,5),10,'MACD底背'),color00FF00;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(CLOSE,A2+1)>CLOSE AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
KDJ底背离:FILTER(B2>0,5),LineThick0,PRECIS0;
STICKLINE(FILTER(B2>0,5),0,20,3,0),color00FFFF;
DRAWTEXT(FILTER(B2>0,5),20,'KDJ底背'),color00FFFF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(CLOSE,A3+1)>CLOSE AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
RSI底背离:FILTER(B3>0,5),LineThick0,PRECIS0;
STICKLINE(FILTER(B3>0,5),0,30,3,0),colorFFFF00;
DRAWTEXT(FILTER(B3>0,5),30,'RSI底背'),colorFFFF00;
POLYLINE(1,100),color0000FF;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIFF"),1));
D1:=REF(CLOSE,C1+1)<CLOSE AND REF("MACD.DIFF",C1+1)>"MACD.DIFF" AND CROSS("MACD.DEA","MACD.DIFF");
MACD顶背离:FILTER(D1>0,5),Linethick0,PRECIS0;
STICKLINE(FILTER(D1>0,5),100,80,3,0),color0066FF;
DRAWTEXT(FILTER(D1>0,5),80,'MACD顶背'),color0066FF;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(CLOSE,C2+1)<CLOSE AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
KDJ顶背离:FILTER(D2>0,5),Linethick0,PRECIS0;
STICKLINE(FILTER(D2>0,5),100,70,3,0),color0000FF;
DRAWTEXT(FILTER(D2>0,5),70,'KDJ顶背'),color0000FF;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(CLOSE,C3+1)<CLOSE AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
RSI顶背离:FILTER(D3>0,5),Linethick0,PRECIS0;

大智慧分时KDJ+MACD+RSI背离公式

0% (0)
0% (10)

关于大智慧分时KDJ+MACD+RSI背离公式的评论:

 以下是对 [大智慧分时KDJ+MACD+RSI背离公式] 的评论,总共:条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们