买好股公式网 > 股票公式 > 大智慧公式 > 大智慧铁血乾坤线副图公式源码

大智慧铁血乾坤线副图公式源码

2012年08月20日 【字体: 人气:

DRAWGBKlast(DATE>900101,strip(RGB(0,0,155),RGB(0,0,60),0));
B1:=REF(C,1);
B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)=0,REF(SS,1),IF(REF(SS,2)=0,REF(SS,2),IF(REF(SS,3)=0,REF(SS,3),IF(REF(SS,5)=0,REF(SS,5),IF(REF(SS,6)=0,REF(SS,6),IF(REF(SS,7)=0,REF(SS,7),0))))));
STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,8,0),COLOR0099FF,LAYER0;
STICKLINE(SS=2,B2,C,8,0),COLOR0099FF,LAYER0;
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,8,0),COLOR0099FF,LAYER0;

{K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,0,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,0,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR006600;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000088;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLOR0000FF;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

drawbmp(VAR1A,(H*1.02),'s.bmp'),align1,valign0,LAYER0;
drawbmp(VAR19,(LOW * 0.99),'b.bmp'),align1,valign0,LAYER0;


X:=BARSLAST(DISPSTATUS=1)+1;
KH:=BACKSET(DISPSTATUS=2,x/1.5+1);
KG:=BARSLAST(CROSS(KH,0.5));
VERTLINE(CROSS(KH,0.5),2),COLORFF9900;
KH4:=BACKSET(DISPSTATUS=2,x/4+1);
KG4:=BARSLAST(CROSS(KH4,1));

ah:hhvall(hhv(h,X)),DOTLINE;
al:llvall(llv(l,X)),DOTLINE;
nnl:=DISPSTATUS=1;
ahl:=ah-al;
q146:=al+ahl*0.146; IF(KG>=0,q146,0);
q191:=al+ahl*0.191; IF(KG>=0,q191,0);
q236:=al+ahl*0.236; IF(KG>=0,q236,0);
q382:=al+ahl*0.382; IF(KG>=0,q382,0);
q500:=al+ahl*0.500; IF(KG>=0,q500,0),DOTLINE;
q618:=al+ahl*0.618; IF(KG>=0,q618,0);
q764:=al+ahl*0.764; IF(KG>=0,q764,0);
q809:=al+ahl*0.809; IF(KG>=0,q809,0);

DRAWTEXT(KG=0,ah*0.998,' 最高.-----'+ah+''),ALIGN0,Color0047FF,LINETHICK3;
DRAWTEXT(KG=0,q809,' 80.9%-----' +q809+''),ALIGN0,Color0099ff,LINETHICK2;
DRAWTEXT(KG=0,q764,' 76.4%-----' +q764+''),ALIGN0,Color00FFff,LINETHICK2;
DRAWTEXT(KG=0,q618,' 61.8%-----'+q618+''),ALIGN0,Color0047FF,LINETHICK2;
DRAWTEXT(KG=0,q500,' 50%-------'+q500+''),ALIGN0,Color00FFff,LINETHICK3;
DRAWTEXT(KG=0,q382,' 38.2%------'+q382+''),ALIGN0,Color0047FF,LINETHICK2;
DRAWTEXT(KG=0,q236,' 23.6%------'+q236+''),ALIGN0,Color0047FF,LINETHICK2;
DRAWTEXT(KG=0,q191,' 19.1%------'+q191+''),ALIGN0,Color00FFff,LINETHICK2;
DRAWTEXT(KG=0,q146,' 14.6%------'+q146+''),ALIGN0,Color00FF99,LINETHICK2;
DRAWTEXT(KG=0,al*1.01,' 最低-----'+al+''),ALIGN0,VALIGN2,Color0047FF,LINETHICK3;

{发展国际金融平台软件}
C1:=(C+H+L+O)/4;CZ1:=EMA(C1,1);CZ2:=EMA(C1,3);CZ3:=EMA(C1,5);
CZ4:=EMA((CZ1+CZ2+CZ3)/3,1);
成者短趋:=EMA(EMA(EMA(CZ4,5),3),100);
WW1:=EMA(C1,8);WW2:=EMA(C1,10);WW3:=EMA(C1,13);
WW5:=EMA((WW1+WW2+WW3)/3,8);
为王中趋:=EMA(EMA(EMA(EMA(WW5,13),10),8),37);
AK1:=EMA((CZ3+WW1+WW2)/3,3);
铁血乾坤线:=EMA(EMA(EMA(AK1,3),5),8);
铁血追杀:IF(铁血乾坤线>REF(铁血乾坤线,1),10,0),COLOR0000FF,LINETHICK0;
铁血等待:IF(铁血乾坤线=REF(铁血乾坤线,1),8,0),COLOR00FFFF,LINETHICK0;
铁血出逃:IF(铁血乾坤线<REF(铁血乾坤线,1),6,0),COLOR00FF00,LINETHICK0;
p:=BARSLAST(DISPSTATUS=1)+1;
E:=llvall(llv(l,p))*0.98;
CG:=(铁血乾坤线-REF(铁血乾坤线,1));
STICKLINE(CG>=0,E+CG*5,E,6,0),Color0000FF,LAYER0;
STICKLINE(CG=0,E+CG*5,E,6,0),Color00FFFF,LAYER0;
STICKLINE(CG<0,E+CG*5,E,6,0),Color00FF00,LAYER0;
FILLRGN(MA(C,2),MA(C,7),MA(C,2)>MA(C,7),RGB(80,0,80),MA(C,2)<MA(C,7),RGB(0,80,0)),LAYER7;


 


 


 

0% (0)
0% (10)

关于大智慧铁血乾坤线副图公式源码的评论:

 以下是对 [大智慧铁血乾坤线副图公式源码] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们