通达信公式
首页 > 通达信公式 > 浏览文章

牛熊线主图指标源码

(admin 2022年11月24日 浏览:次)

牛线:EMA(COST(80),10),COLORYELLOW,LINETHICK2;

熊线:EMA(COST(5),10),COLORGREEN,LINETHICK2;

现价:C,COLORMAGENTA,LINETHICK1;

牛线2:EMA(COST(80),50),COLOR0000FF;

牛熊区间:(牛线-熊线)/熊线*100,NODRAW;

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;

ZN牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORFF0080;

ZN马线:MA(ZN牛线,6),COLORGREEN;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

DRAWTEXT(CROSS(现价,牛线),C*0.99,'★'),COLORRED;

DRAWTEXT(CROSS(现价,熊线),C*0.99,'★'),COLORWHITE;

DRAWICON(CROSS(牛线,牛线2),牛线,1);

上影:(H-MAX(C,O))/MAX(C,O)*100,NODRAW;

实体:(C-O)/REF(C,1)*100,,NODRAW;

下影:(L-MIN(C,O))/MIN(C,O)*100,NODRAW;

中价:(OPEN+CLOSE)/2,NODRAW;

{牛熊线主图指标源码}

【更多精品好指标,欢迎关注本站公众号:爱解公式】

网友评论:
 本文共有0条评论