通达信公式
首页 > 通达信公式 > 浏览文章

MACD金叉与背离副图公式

(admin 2019年06月02日 浏览:次)

MACD金叉与背离副图公式


DIFF:EMA(CLOSE,9)-EMA(CLOSE,17);

DEA:EMA(DIFF,8),COLORFFAA00;

MACD:=2*(DIFF-DEA);

STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;

STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,4,0 ),COLOR00AAFF;

X1:IF(DIFF<0,DIFF,0),COLOR0000FF,LINETHICK2;

X2:IF(DIFF<0,0,DIFF),COLORMAGENTA,LINETHICK1;

X3:IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

X4:IF(DIFF>DEA,DEA,DEA),LINETHICK1,COLORFFBB11;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,DEA*0.86,DEA*0.66,6,0),COLORYELLOW;

DRAWTEXT(低位金叉,DEA*0.86,' 低位金叉'),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,DEA*0.96,DEA*0.76,6,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*1.1,'BUY') ;

DRAWTEXT(二次金叉,DEA*0.96,' 二次金叉'),COLORFF00FF;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,DEA*1.09,DEA*0.86,6,0),COLOR00FF00;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK1;

DRAWTEXT(底背离,DEA*1.09,' 底背离'),COLOR6600FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1;

DRAWTEXT(顶背离,DEA*1.2,' 顶背离'),COLOR00FF00;


网友评论:
 本文共有0条评论